Automation: Problem mit der Relais-Steuerung

Überwachung der Solaranlage per eMail oder Pushover und Steuerung von Geräten mit Smart Home Zentralen. PV-Überschuss Steuerung verbunden mit Geräten und Tasmota Firmware. Wallbox Steuerungen und API Schnittstelle, über die Daten in die Solaranzeigen Datenbanken geschrieben und gelesen werden können. Alles, was man für Steuerungsaufgaben benötigt.

Moderator: Ulrich

Antworten
dreamerpit
Beiträge: 38
Registriert: Mi 16. Aug 2023, 15:10

Automation: Problem mit der Relais-Steuerung

Beitrag von dreamerpit »

Hallo Ulrich,
Ich habe seit ein paar Tagen ein NOUS A1T mit Tasmota software in Betrieb und heute um ein Weiteres ergänzt. Beide Relais funktionieren sowohl über den Test als auch mit jeweils einer Aus bzw. Einschalt-Bedingung. Sobald ich allerdings versuche, zwei Bedingungen z.B. für Relais 1 mit und oder oder zu verknüpfen, funktioniert das nicht. Im log kommen Fehlermeldungen, die ich nicht so wirklich verstehe. Kann bitte jemand helfen...

Wechselrichter ist ein Plenticore plus (mit Reglernr. 17 eingetragen)
Im Dashboard funktioniert alles wie gewünscht, selbst die Relaiszustände bekomme ich angezeigt.

Gruß
Peter

log bei jeweils nur einer Bedingung:
21.09. 19:36:01 |--> - - - - - - - - - - Start Automation - - - - - - - - -
21.09. 19:36:01 INFO PV Leistung: 15.66 W
21.09. 19:36:01 INFO AC Leistung: 249.82 W
21.09. 19:36:01 INFO Bezug: W
21.09. 19:36:01 INFO Einspeisung: 11 W
21.09. 19:36:01 INFO Kapazität: 84 %
21.09. 19:36:01 INFO Broker: Connection Accepted.
21.09. 19:36:01 INFO Relais 1 ist aktiviert.
21.09. 19:36:02 INFO Topic: tele/SteckdoseHeizlüfter/LWT = ONLINE
21.09. 19:36:04 INFO Relais 1 Kontakt 1 ist ausgeschaltet
21.09. 19:36:04 WARN Einspeisung 11 ist niedriger als die Vorgabe: 2000
21.09. 19:36:06 INFO Relais 2 ist aktiviert.
21.09. 19:36:07 INFO Topic: tele/SteckdoseHeizlüfter2/LWT = ONLINE
21.09. 19:36:09 INFO Relais 2 Kontakt 1 ist ausgeschaltet
21.09. 19:36:09 WARN Einspeisung 11 ist niedriger als die Vorgabe: 1200
21.09. 19:36:09 INFO Broker disconnect erfolgreich.
21.09. 19:36:09 ENDE ---------------------------------------------------------

log mit zwei Bedingungen (für Relais 1):
21.09. 19:02:01 |--> - - - - - - - - - - Start Automation - - - - - - - - -
21.09. 19:02:02 INFO PV Leistung: 30.59 W
21.09. 19:02:02 INFO AC Leistung: 249.7 W
21.09. 19:02:02 INFO Bezug: W
21.09. 19:02:02 INFO Einspeisung: 0 W
21.09. 19:02:02 INFO Kapazität: 88 %
21.09. 19:02:02 INFO Broker: Connection Accepted.
21.09. 19:02:02 INFO Relais 1 ist aktiviert.
21.09. 19:02:03 INFO Topic: tele/SteckdoseHeizlüfter/LWT = ONLINE
21.09. 19:02:05 INFO Relais 1 Kontakt 1 ist ausgeschaltet
21.09. 19:02:05 WARN AC Leistung 249.7 ist niedriger als die Vorgabe: 2000
21.09. 19:02:05 WARN Einspeisung 0 ist niedriger als die Vorgabe: 2000
21.09. 19:02:05 INFO Mehr als eine Bedingung aktiv
21.09. 19:02:05 INFO Verknüpfung mit: and
21.09. 19:02:05 INFO 1. Parameter im Vergleich ist falsch. (and)
21.09. 19:02:07 INFO Relais 2 ist aktiviert.
21.09. 19:02:08 INFO Topic: tele/SteckdoseHeizlüfter2/LWT = ONLINE
21.09. 19:02:10 INFO Relais 2 Kontakt 1 ist ausgeschaltet
21.09. 19:02:10 WARN Einspeisung 0 ist niedriger als die Vorgabe: 1200
21.09. 19:02:10 INFO Broker disconnect erfolgreich.
21.09. 19:02:10 ENDE ---------------------------------------------------------

TeamO
Beiträge: 1150
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 24 Mal
Danksagung erhalten: 231 Mal

Re: Automation: Problem mit der Relais-Steuerung

Beitrag von TeamO »

Also ich sehe hier keine Fehlermeldungen und auch keinen Fehler.
Wie wäre es, wenn Du es mal mit Werten testen, die auch ein Schalten der Steckdose ermöglicht?
Deine eingegebenen Bedingungen werden ja laut Log nicht erfüllt, wodurch die Steckdose auch nicht schaltet
AC Leistung 249.7 < Vorgabe 2000
und
Einspeisung 0 < Vorgabe 2000
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

dreamerpit
Beiträge: 38
Registriert: Mi 16. Aug 2023, 15:10

Re: Automation: Problem mit der Relais-Steuerung

Beitrag von dreamerpit »

Hallo Timo,

wie schon geschrieben funktionieren beide Relais mit jeweils einer aus- und ein Bedingung.
Im zweiten Teil des logs siehst du

21.09. 19:02:05 WARN AC Leistung 249.7 ist niedriger als die Vorgabe: 2000
21.09. 19:02:05 WARN Einspeisung 0 ist niedriger als die Vorgabe: 2000
21.09. 19:02:05 INFO Mehr als eine Bedingung aktiv
21.09. 19:02:05 INFO Verknüpfung mit: and
21.09. 19:02:05 INFO 1. Parameter im Vergleich ist falsch. (and)

selbst wenn die Bedingungen erfüllt sind, kommt die Meldung wie in der letzten Zeile und das Relais schaltet nicht.
Gruß
Peter

TeamO
Beiträge: 1150
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 24 Mal
Danksagung erhalten: 231 Mal

Re: Automation: Problem mit der Relais-Steuerung

Beitrag von TeamO »

Eine Warnung ist kein Fehler.
Es meldet doch nur, das Deine AC-Leistung geringer ist, als der Schwellwert zum schalten und das Deine Einspeisung ebenfalls niedriger ist.
Ich habe es gerade bei meinem Testsytem mit zwei Bedingungen getestet und alles funktioniert

Code: Alles auswählen

22.09. 11:14:01 |--> - - - - - - - - - -    Start Automation   - - - - - - - - -
22.09. 11:14:01 INFO AC Leistung: -307.43 W
22.09. 11:14:01 INFO Bezug: 0 W
22.09. 11:14:01 INFO Einspeisung: 305.14 W
22.09. 11:14:01 INFO Kapazität: 6 %
22.09. 11:14:01 INFO Broker: Connection Accepted.
22.09. 11:14:01 INFO Relais 1 ist aktiviert.
22.09. 11:14:02 INFO Topic: tele/NousA1T-2/LWT = ONLINE
22.09. 11:14:04 INFO Relais 1 Kontakt 1 ist ausgeschaltet
22.09. 11:14:04 INFO Einspeisung 305.14 ist größer/gleich Vorgabe: 100
22.09. 11:14:04 INFO SOC 6% ist größer/gleich Vorgabe: 5%
22.09. 11:14:04 INFO Mehr als eine Bedingung aktiv
22.09. 11:14:04 INFO Verknüpfung mit: and
22.09. 11:14:04 INFO Beide Parameter sind wahr. (and)
22.09. 11:14:04 INFO Relais schalten? ja
22.09. 11:14:04 |/ _ Relais 1 Kontakt 1 wird jetzt ein geschaltet.
22.09. 11:14:05 INFO Sent message ID: 4 cmnd/NousA1T-2/power on
22.09. 11:14:07 INFO Broker disconnect erfolgreich.
22.09. 11:14:07 ENDE ---------------------------------------------------------
22.09. 11:15:01 |--> - - - - - - - - - -    Start Automation   - - - - - - - - -
22.09. 11:15:01 INFO AC Leistung: -217.65 W
22.09. 11:15:01 INFO Bezug: 0 W
22.09. 11:15:01 INFO Einspeisung: 208.29 W
22.09. 11:15:01 INFO Kapazität: 7 %
22.09. 11:15:01 INFO Broker: Connection Accepted.
22.09. 11:15:01 INFO Relais 1 ist aktiviert.
22.09. 11:15:02 INFO Topic: tele/NousA1T-2/LWT = ONLINE
22.09. 11:15:04 INFO Relais 1 Kontakt 1 ist eingeschaltet
22.09. 11:15:04 WARN Einspeisung 208.29 ist größer als die Vorgabe: 200
22.09. 11:15:04 WARN SOC 7% ist größer als die Vorgabe: 4%
22.09. 11:15:04 INFO Mehr als eine Bedingung aktiv
22.09. 11:15:04 INFO Verknüpfung mit: or
22.09. 11:15:04 INFO Relais schalten? nein
22.09. 11:15:06 INFO Broker disconnect erfolgreich.
22.09. 11:15:06 ENDE ---------------------------------------------------------
22.09. 11:16:01 |--> - - - - - - - - - -    Start Automation   - - - - - - - - -
22.09. 11:16:01 INFO AC Leistung: -87.18 W
22.09. 11:16:01 INFO Bezug: 0 W
22.09. 11:16:01 INFO Einspeisung: 106.78 W
22.09. 11:16:01 INFO Kapazität: 7 %
22.09. 11:16:01 INFO Broker: Connection Accepted.
22.09. 11:16:01 INFO Relais 1 ist aktiviert.
22.09. 11:16:02 INFO Topic: tele/NousA1T-2/LWT = ONLINE
22.09. 11:16:04 INFO Relais 1 Kontakt 1 ist eingeschaltet
22.09. 11:16:04 INFO Einspeisung 106.78 ist niedriger als die Vorgabe: 250
22.09. 11:16:04 WARN SOC 7% ist größer als die Vorgabe: 4%
22.09. 11:16:04 INFO Mehr als eine Bedingung aktiv
22.09. 11:16:04 INFO Verknüpfung mit: or
22.09. 11:16:04 INFO Einer der beiden Parameter ist wahr. (or)
22.09. 11:16:04 INFO Relais schalten? ja
22.09. 11:16:04 |___ Relais 1 Kontakt 1 wird aus geschaltet.
22.09. 11:16:05 INFO Sent message ID: 4 cmnd/NousA1T-2/power off
22.09. 11:16:07 INFO Broker disconnect erfolgreich.
22.09. 11:16:07 ENDE ---------------------------------------------------------
22.09. 11:17:01 |--> - - - - - - - - - -    Start Automation   - - - - - - - - -
22.09. 11:17:01 INFO AC Leistung: -60.75 W
22.09. 11:17:01 INFO Bezug: 0 W
22.09. 11:17:01 INFO Einspeisung: 98.11 W
22.09. 11:17:01 INFO Kapazität: 7 %
22.09. 11:17:01 INFO Broker: Connection Accepted.
22.09. 11:17:01 INFO Relais 1 ist aktiviert.
22.09. 11:17:02 INFO Topic: tele/NousA1T-2/LWT = ONLINE
22.09. 11:17:04 INFO Relais 1 Kontakt 1 ist ausgeschaltet
22.09. 11:17:04 WARN Einspeisung 98.11 ist niedriger als die Vorgabe: 500
22.09. 11:17:04 WARN SOC 7% ist niedriger als die Vorgabe: 10%
22.09. 11:17:04 INFO Mehr als eine Bedingung aktiv
22.09. 11:17:04 INFO Verknüpfung mit: and
22.09. 11:17:04 INFO 1. Parameter im Vergleich ist falsch. (and)
22.09. 11:17:06 INFO Broker disconnect erfolgreich.
22.09. 11:17:06 ENDE ---------------------------------------------------------
Wie schon geschrieben, stell doch einfach mal Werte ein, die auch zutreffen können.
Zum Beispiel AC 200 und Einspeisung 0 oder was halt aktuell bei Dir der Fall ist und auch zutreffen würde.
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

dreamerpit
Beiträge: 38
Registriert: Mi 16. Aug 2023, 15:10

Re: Automation: Problem mit der Relais-Steuerung

Beitrag von dreamerpit »

Hallo zusammen,
Asche auf mein Haupt. Fehler lag bei mir. Nun funktioniert alles.
Ich habe beim testen zwischendurch den Haken für das generelle einschalten des zweiten Relais herausgenommen
und es hat ein wenig gedauert, die Texte sinngemäß zu verstehen.
Wenn ich lese: 1. Parameter im Vergleich ist falsch,
dann heisst das für mich erstmal, es liegt ein Fehler vor. Es wäre vielleicht einfacher, wenn da stehen würde, Bedingung ist erfüllt oder ist nicht erfüllt.
Ich möchte hier aber keine philosophische Diskussion führen.
Also es läuft und danke für die Unterstützung.....

Gruß
Peter

Antworten

Zurück zu „Überschuss Steuerung, Anlagenüberwachung, Anbindung an die Heizung, API Schnittstelle und vieles Andere mehr.“