Hilfeee !!!

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Antworten
ToTo_OB
Beiträge: 46
Registriert: Sa 19. Jun 2021, 11:16
Hat sich bedankt: 3 Mal

Hilfeee !!!

Beitrag von ToTo_OB »

Hilfeeeee !!!!

Habe jetzt nach Anweisung die Multi-Regler Version gemacht.

Regler 1 läuft

Bei der Homematic bekomme ich aber Fehlermeldungen.

06.01. 16:22:11 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
06.01. 16:22:11 -Multi-Regler-Ausgang. -1
06.01. 16:22:11 -HM Übertragung mit _math Datei.
06.01. 16:22:11 -Daten zur HomeMatic gesendet.
06.01. 16:22:11 -OK. Datenübertragung erfolgreich.
06.01. 16:22:11 |---------------- Stop huawei_LAN.php ---------------------------
06.01. 16:22:12 -Verarbeitung von: '2.user.config.php' Regler: 72
06.01. 16:22:12 |---------------- Start hm_geraet.php --------------------------
06.01. 16:22:12 -HomeMatic: 192.168.2.130 Port: 80 GeräteID: 1
06.01. 16:22:12 + -Die Daten werden ausgelesen...
06.01. 16:23:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
06.01. 16:23:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
06.01. 16:24:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
06.01. 16:24:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
06.01. 16:25:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
06.01. 16:25:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
06.01. 16:26:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
06.01. 16:26:02 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
06.01. 16:27:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
06.01. 16:27:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
06.01. 16:28:01 -Zu viele PHP Scripte: multi_regler_auslesen.php


was läuft hier falsch?

Gruß
Torsten

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Hilfeee !!!

Beitrag von Ulrich »

Der LOG Eintrag besagt, dass die HomeMatic nicht oder nicht richtig antwortet. Die Verbindung ist entweder nicht richtig angegeben oder das XML Addon nicht installiert.
Bitte poste dein Problem nicht mehrfach. So etwas macht man nicht.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

ToTo_OB
Beiträge: 46
Registriert: Sa 19. Jun 2021, 11:16
Hat sich bedankt: 3 Mal

Re: Hilfeee !!!

Beitrag von ToTo_OB »

Hallo Ulrich,

entschuldige bitte den doppelten Post. Ich habe vergessen den anderen zu löschen.

Es wird leider immer merkwürdiger. Ich habe beide Pi´s neu gestartet.

In der Homematic läuft API 1.22

In der Solaranzeige scheint er jetzt die 2.user.config.php garnicht mehr aufzurufen. Zumindest finde ich das im LOG nicht mehr.

ich habe folgende Einträge in der Datei gemacht:

//
$Regler = "72";
//
/******************************************************************************
// Raspberry Gerätenummer Raspberry Gerätenummer Raspberry Gerätenummer
// Falls mehr als ein Gerät pro Raspberry betrieben wird.
// Es ist die Reihenfolge der Geräte und taucht auch in der Nummerierung
// der x.user.config.php Dateien auf
******************************************************************************/
// GeräteID bzw. GeräteNummer Muss gleich mit der x.user.config.php sein.
// Bitte nur bei einer Multi-Regler-Version ändern. [ 1 bis 6 ]
$GeraeteNummer = "2";
//
// Bei einem Micro Wechselrichter von AEconversion oder LiCom Box von Effekta

sowie:

// HM_Systemvariable 1
// $HM_Systemvariable[1] = "Test"; // Variable 1
// $HM_Systemvariable[2] = "DutyCycle"; // Variable 2


*******************************************************************************/
//
// HM_Geraet 1
// $HM_Geraetetyp[1] = "HmIP-STHO"; // Typenbezeichnung
// $HM_Seriennummer[1] = "000EDF29AF0A5D"; // Seriennummer
HM_Geraet 1
$HM_Geraetetyp[1] = "HmIP-eTRV-B"
$HM_Seriennummer[1] = "00201D89BC8CF6"

$HM_Geraetetyp[2] = "HMIP-PSM"
$HM_Seriennummer[2] = "0001D3C9A4F4B1"
//
//$HM_Systemvariable[2] = "DutyCycle"
//
/******************************************************************************
// MQTT Protokoll MQTT Protokoll MQTT Protokoll MQTT Protokoll


Wo liegt der Fehler, ich bin total ratlos

Lieben Gruß
Torsten

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Hilfeee !!!

Beitrag von Ulrich »

Die Fehlermeldung wirst du in der LOG Datei /var/www/html/php.log finden.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Antworten

Zurück zu „Multi-Regler-Version [ bis zu 6 Geräten an einem Raspberry Pi ]“