[gelöst] Sungrow SH10RT-V112 Fehler beim auslesen

Welche Geräter können mit dieser Anzeige benutzt werden?
Laderegler, Wallboxen, Batterie-Management-Systeme, WLAN Schalter mit Tasmota Firmware und Wechselrichter

Moderator: Ulrich

hru
Beiträge: 66
Registriert: Fr 16. Feb 2024, 09:16

[gelöst] Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von hru »

Hallo zusammen,

ich habe Regler 70 eingetragen, und die IP-Adresse des hinteren LAN-Eingangs und Port 502 und WR_Adresse = 1.
Ist WR_Adresse = 1 richtig?

Aber die Daten können nicht ausgelesen werden.

Code: Alles auswählen

26.02. 22:02:01 |----------------   Start  sungrow.php    --------------------------
26.02. 22:02:01    -Sungrow: 192.168.178.64 Port: 502 GeräteID: 1
26.02. 22:02:01 +  -Die Daten werden ausgelesen...
26.02. 22:02:01    -Firmware: ARM_SAPPHIRE-H_V11_V01_B
26.02. 22:02:01    -Seriennummer: xxxx
26.02. 22:02:08    -Lesefehler => Ausgang.
26.02. 22:02:08 |----------------   Stop   sungrow.php    --------------------------
Woran kann das liegen?

Danke für jeden Tipp.

Gruß Hartmut
PV-Anlage mit Sungrow Wechselrichter SH10RT-V112 und Speicher SBR128
MyPV AC ELWA 2 Heizstab zur Brauchwassererwärmung
Zwei Stromzähler ZPA GH305

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von Ulrich »

Wenn du einen WLAN sDongle benutzt, gibt es dafür eventuell ein Firmwareupdate? Kannst du das Gerät einmal testweise per LAN anschließen?
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

hru
Beiträge: 66
Registriert: Fr 16. Feb 2024, 09:16

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von hru »

Hallo,

der Wechselrichter ist mit 2 LAN-Kabeln angeschlossen.

Eins geht an den unter 3.) in der Anleitung beschriebenen Anschluss
"WLAN-Anschluss" [Steckverbinder für das WiNet-S-Modul]
und das andere LAN-Kabel geht in den unter 4.) in der Anleitung beschriebenen
hinteren "LAN-Anschluss" [Steckverbinder für ein EMS oder Modbus TCP].

Der WR hat auch zwei IP-Adressen bekommen.
Ich habe die IP des LAN-Anschlusses in der Solaranzeige-Konfigurationsdatei "/var/www/html/user.config.php" eingetragen.

Hier zum Abgleich alle Einstellungen in der Datei:

Code: Alles auswählen

$Regler = "70";
$GeraeteNummer = "1";
$Seriennummer = "0000000000";
$Zugang_Kennwort = "";
$HF2211 = false;
$Batteriepacks = "1";
$PylonTech = "2000";
$WR_IP = "192.168.178.64";
$WR_Port = "502";
$WR_Adresse = "1";
$Objekt = "PV-Anlage xxx";
$InfluxDB_local = true;
$InfluxDBLokal  = "solaranzeige";
$Wiederholungen = 1;
$InfluxDB_remote = false;
$InfluxPort = 8086;
$InfluxDBName  = "solaranzeige";
$InfluxAdresse = "";
$InfluxSSL = false;
$InfluxUser = "";
$InfluxPassword ="";
$InfluxDaylight = false;
$Homematic = false;
$Homematic_IP = "xxx.xxx.xxx.xxx";
$HomeMaticVar = "";
$HM_auslesen = false;
$HM_Geraetetyp[1] = "";
$HM_Seriennummer[1] = ""; 
$MQTT = false;
$MQTTBroker = "localhost";
$MQTTPort = 1883;
$MQTTBenutzer = "";
$MQTTKennwort = "";
$MQTTSSL = false;
$MQTTKeepAlive = 60;
$MQTTGeraet = "box1";
$MQTTAuswahl = "";
$MQTTTopic[1] = "solaranzeige/befehl/1/#";
$Topic = "sonoff";
$Wetterdaten = false;
$APPID = "";
$StandortID = "2925533";
$Prognosedaten = "keine";
$AccessToken = "";
$PrognoseItem = "inverter"; 
$PrognoseID = "0";
$Algorithmus = ""; 
$Messenger = false;
$Messengerdienst[1] = "Pushover";
$API_Token[1] = " ";
$User_Key[1] = "";
$aWATTar = false;
$Aufschlag = "0";
$aWATTarLand = "DE";
$USBRegler         = "Ethernet";
$USBDevice = "";
$Platine = "Raspberry Pi 4 Model B Rev 1.4";
$Alpha_ESS = 0;
Ich bin mir nicht sicher, ob die Angabe "1" bei dem Parameter $WR_Adresse korrekt ist.
Laut Einträgen in anderen Foren muss dort eine Angabe des WR eingetragen werden.
Ich konnte eine solche Angabe aber in der Sungrow iCloud-Umgebung nicht finden.

Gruß Hartmut
PV-Anlage mit Sungrow Wechselrichter SH10RT-V112 und Speicher SBR128
MyPV AC ELWA 2 Heizstab zur Brauchwassererwärmung
Zwei Stromzähler ZPA GH305

hru
Beiträge: 66
Registriert: Fr 16. Feb 2024, 09:16

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von hru »

Hallo,

in einem anderen Post hier im Forum wo es auch Probleme mit dem Auslesen eines Sungrow Wechselrichters gab, wurde gesagt dass man statt "1" beim Parameter $WR_Adresse besser "001" angeben müsse.

Das hat bei mir keine Änderung gebracht:

Code: Alles auswählen

27.02. 22:15:01 |----------------   Start  sungrow.php    --------------------------
27.02. 22:15:01    -Sungrow: 192.168.178.64 Port: 502 GeräteID: 001
27.02. 22:15:01 +  -Die Daten werden ausgelesen...
27.02. 22:15:01    -Firmware: ARM_SAPPHIRE-H_V11_V01_B
27.02. 22:15:01    -Seriennummer: ...
27.02. 22:15:08    -Lesefehler => Ausgang.
27.02. 22:15:08 |----------------   Stop   sungrow.php    --------------------------
Gruß Hartmut
PV-Anlage mit Sungrow Wechselrichter SH10RT-V112 und Speicher SBR128
MyPV AC ELWA 2 Heizstab zur Brauchwassererwärmung
Zwei Stromzähler ZPA GH305

hru
Beiträge: 66
Registriert: Fr 16. Feb 2024, 09:16

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von hru »

Hallo,

jetzt habe ich mal die IP-Adresse des LAN-Anschlusses vorne eingetragen:
Der heißt laut Doku zwar "WLAN-Anschluss" [Steckverbinder für das WiNet-S-Modul], es steckt aber ein LAN-Kabel drin.

Code: Alles auswählen

27.02. 22:22:01 |----------------   Start  sungrow.php    --------------------------
27.02. 22:22:01    -Sungrow: 192.168.178.64 Port: 502 GeräteID: 1
27.02. 22:22:01 +  -Die Daten werden ausgelesen...
27.02. 22:22:01    -Firmware: ARM_SAPPHIRE-H_V11_V01_B
27.02. 22:22:08    -Lesefehler => Ausgang.
27.02. 22:22:08 |----------------   Stop   sungrow.php    --------------------------
27.02. 22:23:02 |----------------   Start  sungrow.php    --------------------------
27.02. 22:23:02    -Sungrow: 192.168.178.45 Port: 502 GeräteID: 1
27.02. 22:23:02 +  -Die Daten werden ausgelesen...
27.02. 22:23:02    -Firmware: ARM_SAPPHIRE-H_V11_V01_B
27.02. 22:23:02    -Seriennummer: ...
27.02. 22:23:19    -Lesefehler => Ausgang.
27.02. 22:23:19 *  -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
27.02. 22:23:58    -Schleife 1 Ausgang...
27.02. 22:23:58    -OK. Datenübertragung erfolgreich.
27.02. 22:23:58 |----------------   Stop   sungrow.php    --------------------------
Was bedeutet das jetzt?
Ist das jetzt korrekt so?
Warum steht dann noch "Lesefehler => Ausgang."?
Und warum fehlt bei der Ausgabe von 22:22 Uhr die Zeile mit der Seriennummer?

Gruß Hartmut
PV-Anlage mit Sungrow Wechselrichter SH10RT-V112 und Speicher SBR128
MyPV AC ELWA 2 Heizstab zur Brauchwassererwärmung
Zwei Stromzähler ZPA GH305

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von Ulrich »

Ob bei $WR_Adresse "1" oder "01" oder "001" ist egal. Das ist alles das selbe. Hauptsache die MODBUS Geräte-Adresse ist 1

Die LOG Datei deutet auf einen oder mehrere Fehler beim Auslesen hin. Handelt es sich um ein SH oder SG Modell? Ist eine Batterie vorgesehen, aber noch nicht angeschlossen? Ist es eventuell ein neues oder ein Sondermodell?
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

hru
Beiträge: 66
Registriert: Fr 16. Feb 2024, 09:16

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von hru »

Hallo,

es ist ein SH10RT und es ist eine Batterie dabei, die hat die Bezeichnung SBR128.

Die Anlage wurde Ende August 2023 installiert.
Ob es sich dabei um ein neues oder um ein Sondermodell handelt, kann ich nicht sagen.
Woran kann man das erkennen?

Gruß Hartmut
PV-Anlage mit Sungrow Wechselrichter SH10RT-V112 und Speicher SBR128
MyPV AC ELWA 2 Heizstab zur Brauchwassererwärmung
Zwei Stromzähler ZPA GH305

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von Ulrich »

Bitte melde dich einmal per eMail.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Benutzeravatar
Knoote
Beiträge: 16
Registriert: Mi 9. Nov 2022, 06:52
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von Knoote »

Habt Ihr das Problem gefunden?
Sungrow SH10RT; SBR096, 13,5 KWp

hru
Beiträge: 66
Registriert: Fr 16. Feb 2024, 09:16

Re: Sungrow SH10RT-V112 Fehler beim auslesen

Beitrag von hru »

Ulrich hat geschrieben:
Mi 28. Feb 2024, 12:20
Bitte melde dich einmal per eMail.
Hallo,

mach ich heute Abend, wenn ich zu Hause bin und Zugriff auf den Raspi habe.

Gruß Hartmut
PV-Anlage mit Sungrow Wechselrichter SH10RT-V112 und Speicher SBR128
MyPV AC ELWA 2 Heizstab zur Brauchwassererwärmung
Zwei Stromzähler ZPA GH305

Antworten

Zurück zu „Regler, Wallboxen und Wechselrichter“