Probleme mit Solaredge SE5k

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

BerndWG
Beiträge: 13
Registriert: Mi 21. Sep 2022, 15:14

Probleme mit Solaredge SE5k

Beitrag von BerndWG »

Hallo zusammen,

ich bin total neu hier und habe heute versucht die Solaranzeige mit einem Solaredge SE5k zu verbinden.
Ich hatte das schon mal vor einem Jahr versucht, habs dann aber schell aufgegeben.
Ich hab von Solaredge die Bestätigung dass Modbus auf Port 1502 aktiv ist.
Jetzt heute neuer Versuch mit 6.0.1.

Prinzipiell zeigt Grafana aktuell nur Geräte-Status = 0 an.

ca. 17:26 hab ich den WR und den PI neu gestartet.

Im log sehe ich aktuell folgendes:
20.03. 17:27:26 |---------------- Stop solaredge_serie.php ---------------
20.03. 17:28:01 |---------------- Start solaredge_serie.php ---------------
20.03. 17:28:01 -SolarEdge: 192.168.178.89 Port: 1502 GeräteID: 1
20.03. 17:28:01 o -Hardware Version: 4B
20.03. 17:28:01 XX -Kein Kontakt zum Wechselrichter 192.168.178.89, Port: 1502, Fehlermeldung: Connection refused
20.03. 17:28:01 XX -Exit....
20.03. 17:28:01 |---------------- Stop solaredge_serie.php ---------------
20.03. 17:29:02 |---------------- Start solaredge_serie.php ---------------
20.03. 17:29:02 -SolarEdge: 192.168.178.89 Port: 1502 GeräteID: 1
20.03. 17:29:02 o -Hardware Version: 4B
20.03. 17:30:02 + -40000:
20.03. 17:39:02 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
20.03. 17:39:02 -WattstundenGesamtHeute: 0
20.03. 17:39:02 |---------------- Stop solaredge_serie.php ---------------
20.03. 17:40:01 |---------------- Start solaredge_serie.php ---------------
20.03. 17:40:01 -SolarEdge: 192.168.178.89 Port: 1502 GeräteID: 1
20.03. 17:40:01 o -Hardware Version: 4B
20.03. 17:41:01 + -40000:
20.03. 17:50:01 |------------------- Start wetterdaten.php --------------------
20.03. 17:50:01 WET-API Abfrage -1 Sekunden nach jeder vollen Stunde.
20.03. 17:50:02 -Alle 10 Minuten werden die Statistikdaten übertragen.
20.03. 17:50:02 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
20.03. 17:50:02 -WattstundenGesamtHeute: 0
20.03. 17:50:02 |---------------- Stop solaredge_serie.php ---------------
20.03. 17:50:21 WET-Wetterdaten ausgeschaltet.
20.03. 17:50:21 WET-Prognoseeinstellung: keine
20.03. 17:50:21 WET-Wetterprognose ausgeschaltet.
20.03. 17:50:21 |------------------- Stop wetterdaten.php ---------------------
20.03. 17:51:02 |---------------- Start solaredge_serie.php ---------------
20.03. 17:51:02 -Zentraler Timestamp: 1710953461
20.03. 17:51:02 -SolarEdge: 192.168.178.89 Port: 1502 GeräteID: 1
20.03. 17:51:02 -WattstundenGesamtHeute: 0
20.03. 17:51:02 o -Hardware Version: 4B
20.03. 17:52:02 + -40000:
20.03. 17:53:02 + -40121:
20.03. 17:54:02 + -40295:
20.03. 17:55:02 + -404695:
20.03. 17:56:02 + -4E100:
20.03. 17:57:02 + -4E16C:
20.03. 17:58:02 + -4E176:
20.03. 17:59:02 + -4E200:
20.03. 18:00:02 + -4E16C:

Steht die Modbus Verbindung?
Wo kann ich prüfen was schief geht?

Das SolarEdge Dashboard hat bei beim laden auch gemeldet "depends on Angular, which is deprecated".
Zusätzlich was muss ich anpassen um den Einphasen SE5k korrekt angezigt zu bekommen?

Grüße
Bernd
18 x Solarwatt Vision 60M mit SolarEdge P370 Leistungsoptimierer
SolarEdge StoreEdge SE5000H-RWS
SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss
LG RESU10H

BerndWG
Beiträge: 13
Registriert: Mi 21. Sep 2022, 15:14

Re: Probleme mit Solaredge SE5k

Beitrag von BerndWG »

ich hab den trace-level auch mal von 7 auf 8 gestellt, jetzt sehe ich im log auch "arrays" alle Werte sind da aber 0.
18 x Solarwatt Vision 60M mit SolarEdge P370 Leistungsoptimierer
SolarEdge StoreEdge SE5000H-RWS
SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss
LG RESU10H

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Probleme mit Solaredge SE5k

Beitrag von Ulrich »

Die Verbindung ist fehlerhaft. Es wird nichts ausgelesen.

Der Wechselrichter erkennt eine neue MODBUS Verbindung nur innerhalb 2 Minuten nach dem Neustart.

Ist der Port richtig? 1502, nicht 502?

Ist die GeräteID richtig? 1
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

BerndWG
Beiträge: 13
Registriert: Mi 21. Sep 2022, 15:14

Re: Probleme mit Solaredge SE5k

Beitrag von BerndWG »

Update:
- mit nmap hatte ich gerpüft ob port 1502 offen ist
- beim ersten check war der Port "open" somit ging ich davon aus, dass das passt.
- dann plötzlich nicht mehr
- hab dann ein tail -f auf solaranzeige.log gestartet und parallel immer mit nmap gerüft ob der Port offen ist
- immer dann wenn die Solaranzeige eine Abfrage gestartet hatte (alle 10 min) war der Port am WR offen
- hab dann mal die Geräte ID auf 2 gestellt
- jetzt kommen Daten und Grafana sagt jetzt "läuft"

>> ggf. als Hinweis für die SolarEdge Besitzer und die, die einen SE WR mit Solaranzeige nutzen wollen
- Port ist in den schon mehrfach erwähnten 2 Min nach Start des WR offen
- und wenn die Solaranzeige verbunden ist immer dann wenn abgefragt wird
- sonst zeigt nmap "closed" an.
>> Info: der SE WR hat einen Schalter mit den Stellungen P 1 0, und steht normal auf 1, neutart = hebel auf 0 und wieder auf 1
dann bootet der WR und es dauert ein bisschen (leise Klackergeräusche)
den PI habe ich direkt nach WR Neustart (Hebel wieder auf 1) rebootet
dies passte dann zeitlich um beide zu verbinden

Jetzt geht's ans Tuning.
Die in Grafana angezeigten Werte passen nicht zu dem was die SE App anzeigt.
Jegliche Hinweise wie der SE5000H (Einphasen) in Grafana anzupassen ist sind will kommen.

Ich hab einen SolarEdge StoreEdge SE5000H-RWS so wie ein SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss.
Warum der WR ID 2 hat muss mir SolarEdge noch erklären, vermutlich ist dann der MTR die ID 1.
18 x Solarwatt Vision 60M mit SolarEdge P370 Leistungsoptimierer
SolarEdge StoreEdge SE5000H-RWS
SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss
LG RESU10H

TeamO
Beiträge: 1150
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 24 Mal
Danksagung erhalten: 231 Mal

Re: Probleme mit Solaredge SE5k

Beitrag von TeamO »

Die SE-App zeigt meines Wissens nach 15 Minuten Werte an und nicht die Live-Daten.
Ich verlasse mich eher auf meine Solaranzeige als auf die App.
Wegen der ID, die muss nicht zwingend 1 sein. Bei mir ist sie zum Beispiel 11.
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

BerndWG
Beiträge: 13
Registriert: Mi 21. Sep 2022, 15:14

Re: Probleme mit Solaredge SE5k

Beitrag von BerndWG »

Die SE App zeigt mir heute W-Werte zwischen 1600W und 2000W an, die Solaranzeige nur max. 500W.
Das passt nicht zusammen.

viewtopic.php?t=1069
Sagt auch explizit: SolarEdge 3 Phasen Wechselrichter (Für 1 Phasen Geräte muss das Dashboard geändert werden)
Gibt es einen Hinweis was zu tun ist?
18 x Solarwatt Vision 60M mit SolarEdge P370 Leistungsoptimierer
SolarEdge StoreEdge SE5000H-RWS
SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss
LG RESU10H

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Probleme mit Solaredge SE5k

Beitrag von Ulrich »

Schalte die SE APP doch einfach einmal aus, dann sollten die Werte stimmen. Das was an dem Dashboard geändert werden muss dreht sich nur um das "Aufhübschen". Die Werte werden dadurch nicht geändert.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

BerndWG
Beiträge: 13
Registriert: Mi 21. Sep 2022, 15:14

Re: Probleme mit Solaredge SE5k

Beitrag von BerndWG »

So ...

Ich bin jetzt ein bisschen weiter.
Alle Leistungsanzeigen hab ich in der Tagesansicht im Griff und sehen gut aus und entsprechen dem was mir die SE App (die ich nicht abgeschaltet habe weil das meine Kontrollreferenz ist) anzeigt.

Ich warte immer noch auf Einstellungsdaten von SolarEdge-Support bzw. von meinem Installateur.

Ich hab ja folgendes am Start:
- SolarEdge StoreEdge SE5000H-RWS
- SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss
- LG RESU10H

SE behauptet der WR wäre ID#1 und der Meter ID#2 und ich sollte ID#1 abfragen.
Aktuell frage ich die ID#2 ab und bekomme nutzbare Daten von der ID#1 kommt wie oben beschrieben nichts brauchbares.

Frage an die Community, hat einer von euch die gleiche Konstellation und was fragt ihr ab?

Was ich adjustieren musste war die PV Leistung, hier hätte ich erwartet, dass dies die Leistung ist die aus den Zelle kommt, um den Wert zu sehen muss ich noch die Leistung die in die Batterie geht noch dazu rechnen.

Was somit auch nicht passt ist die erzeugt Energie (Wh_heute) der Wert passt überhaupt nicht, denke das hängt aber mit der o.g. Leistungsdarstellung zusammen, nur ich hab keine Wh_Batt_heute ...
Hat da jemand einen Tipp?

Was mir somit somit fehlt sind die Energie pro Tag/Monat/Jahr Werte für PV, Batt-in, Batt-out, Verbrauch, Bezug und Einspeisung.
Da bräuchte ich mal Hilfe wie ich das bekomme.

Ich freue mich über die Rückmeldungen und bedanke mich auch schon mal dafür.

Schon ein cooles Ding was der Ulrich da zusammengestellt hat, aber um mich von der SE App zu verabschieden zu können fehlt mir noch bisschen was.

Ich will eigentlich bis Ende des Jahr ohne SE klar kommen, da ich die nicht mit meinen Daten füttern will und ich davon ausgehe, dass die in absehbarer Zeit dafür Geld wollen.

Danke und Grüß
Bernd.
18 x Solarwatt Vision 60M mit SolarEdge P370 Leistungsoptimierer
SolarEdge StoreEdge SE5000H-RWS
SolarEdge SE-MTR-3Y-400V-A Energiezähler mit MODBUS Anschluss
LG RESU10H

StephanH
Beiträge: 16
Registriert: So 25. Feb 2024, 00:21
Hat sich bedankt: 1 Mal

Re: Probleme mit Solaredge SE5k

Beitrag von StephanH »

Hi ich weiß nicht genau ob ich hier richtig bin aber heute fielen mir starke unterschiede zwischen der solaranzeoge und meiner SE app auf WR ist ein SE10K RBW der heute 64kwh produziert hat. Die solaranzeige teilte mir aber nur 50kwh mit weiß einer woran das liegt.
Dateianhänge
SmartSelect_20240413_222453_WhatsApp.jpg
Screenshot_20240413_213743_mySolarEdge.jpg

TeamO
Beiträge: 1150
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 24 Mal
Danksagung erhalten: 231 Mal

Re: Probleme mit Solaredge SE5k

Beitrag von TeamO »

Also ich sehe hier, dass Dein WR 51,0468kWh erzeugt hat. Das passt ja annähernd zu den 50kWh der Solaranzeige.
Du musst bei den Balken beachten, dass der Wert "Ins Haus" beim SE wohl auch die Entladung der Batterie enhält.
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

Antworten

Zurück zu „Allgemeines“