Fehler beim speichern in InfluxDB

Wie kann ich die Daten der Geräte grafisch darstellen? Fragen, Beispiele und Antworten zu InfluxDB und Grafana
Mykira
Beiträge: 5
Registriert: So 25. Dez 2016, 10:09

Re: Fehler beim speichern in InfluxDB

Beitrag von Mykira »

Gibt es für das o.a. Problem schon eine Lösung?
Ich betreibe einen Victron BMV 702 und einen SmartSolar Mppt 100/30 mit Victron original Kabeln.
Der BMV 702 funktioniert einwandfrei, aber der Solarregler erzeugt dieselben Fehler. Mal keinen in einer Stunde, aber meistens mehrere pro Stunde in unregelmäßigen Abständen. Ein Vertauschen der Kabel, oder nur ein Gerät bringt keine Änderung. Nur der Solarregler bringt die Fehler.


Gruß Ulf

Benutzeravatar
Ulrich
Administrator
Beiträge: 1492
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Fehler beim speichern in InfluxDB

Beitrag von Ulrich »

Ich gehe davon aus, dass Du den Laderegler zusätzlich über Bluetooth ausließt und den BMV nicht. Die Bluetooth Verbindung nutzt das gleiche Protokoll wie das VE.direct Kabel. Die beiden kommen sich in die Quere. Schalte bitte einmal Bluetooth ab, dann sollte es funktionieren.
--------------------------------------
Ulrich [Admin]

Mykira
Beiträge: 5
Registriert: So 25. Dez 2016, 10:09

Re: Fehler beim speichern in InfluxDB

Beitrag von Mykira »

Leider ist das nicht die Ursache. Mein Laderegler hat kein eingebautes Bluetooth. Der BMV 702 ja auch nicht. Ich hatte sie aber beide vorher mit den Victron Bluetooth Modulen betrieben. Jetzt sind beide mit VE.direct Kabel angeschlossen.
Testweise habe ich auch mal das Venus OS benutzt. Da traten auch keine Fehler auf.

Nafets
Beiträge: 18
Registriert: Di 10. Sep 2019, 10:25

Re: Fehler beim speichern in InfluxDB

Beitrag von Nafets »

Möchte den weiteren Verlauf bei mir noch nachtragen:

Mit der Hilfe von Ulrich haben wir herausgearbeitet, dass die ursprünglich deutlich öfters auftretenden Fehler mit dem damals noch angelegten VE.smart Networking (=virtuelles Victron Netz via BLE) zusammenhingen.

Nachdem ich das VE.smart Networking vollkommen deaktiviert habe, wurden die Fehler deutlich weniger und bewegen sich in der Größenordnung wie von @Mykira beschrieben.


Ich habe einen (bzw. seit kurzem zwei) SmartSolar Regler mit original USB Kabel angeschlossen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 1492
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Fehler beim speichern in InfluxDB

Beitrag von Ulrich »

Seit Heute gibt es eine nochmals geänderte Leseroutine für die Victron Regler. Bitte noch einmal ein Update ausführen.
--------------------------------------
Ulrich [Admin]

Nafets
Beiträge: 18
Registriert: Di 10. Sep 2019, 10:25

Re: Fehler beim speichern in InfluxDB

Beitrag von Nafets »

Hab jetzt seit etwas über 1 Stunde die neue Version (mit zwei MPPT) am laufen und noch KEINEN Fehler !

Chapeau, Ulrich

Nafets
Beiträge: 18
Registriert: Di 10. Sep 2019, 10:25

Re: Fehler beim speichern in InfluxDB

Beitrag von Nafets »

Nach 12 Stunden nur einen Fehler im .log

Benutzeravatar
Ulrich
Administrator
Beiträge: 1492
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Fehler beim speichern in InfluxDB

Beitrag von Ulrich »

Ein Fehler pro 12 Stunden ist normal. Besser geht es nicht.
--------------------------------------
Ulrich [Admin]

Nafets
Beiträge: 18
Registriert: Di 10. Sep 2019, 10:25

Re: Fehler beim speichern in InfluxDB

Beitrag von Nafets »

Kurz vor 24 Stunden gabs noch nen zweiten Fehler

Ist ein super Ergebnis; Vielen Dank Ulrich !

Was hast denn eigentlich geändert im .php ?

Mykira
Beiträge: 5
Registriert: So 25. Dez 2016, 10:09

Re: Fehler beim speichern in InfluxDB

Beitrag von Mykira »

Ja, ich kann mich bei Ulrich auch nur bedanken. Mein BMV 702 und der MPPT Regler 100/30 laufen jetzt wunderbar zusammen. In den letzten zwei Tagen hatte ich auch nur einen Fehler. Damit bin ich mehr als zufrieden.
Kann den Support nur loben.

Antworten