SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

Hallo Ulrich,

so, neue Erkenntnis..der shelly 1PM braucht ja noch eine Grundeinstellung,LED Config, wie das Relais schalten soll wie die Daten etc pp.Das Problemkind nennt sich "Template"
Ein passendes ist bisher nicht gefunden, aber verschiedene(im Netz klagen einige über das gleiche Problem) Templates lassen die IP Oberfläche des Shelly 1PM anderes aussehen..und auch da hängt dann die Datenbankschreiberei von den Werten ab..
Beispiel>>>

name: Summen
time Wh_Gesamt Wh_Gestern Wh_Heute
---- --------- ---------- --------
2023-01-18T10:20:01Z 22 0
2023-01-18T10:19:01Z 21 21
2023-01-18T10:18:02Z 21 21
2023-01-18T10:17:01Z 20 20
2023-01-18T10:16:01Z 20 20
root@fu26keller:~# influx -host localhost -port 8086 -database shelly -precision rfc3339 -execute "select * from Summen order by time desc limit 5"
name: Summen
time Wh_Gesamt Wh_Gestern Wh_Heute
---- --------- ---------- --------
2023-01-18T10:28:01Z 24 24
2023-01-18T10:27:01Z 24 0
2023-01-18T10:25:01Z 24 24
2023-01-18T10:24:01Z 24 0
2023-01-18T10:23:01Z 23 0

mal ist der Wert "Wh_Heute" akt, mal null, je nachdem wann ich das Template als ganze Zeile austausche (unter Einstellungen, sonstige Konfiguration, oberste Zeile)

Da ich bisher nix richtiges zu den Einstellungen des 1PM gefunden hab, leg ich die Shellys1PM erstmal auf die Seite, bis dieses richtige Template gefunden ist.Vielleicht liest ja jmd der die roten Dinger erfolgreich in Betrieb hat, mit und stellt nen Screenshot ein

gruss
Andreas
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

Bogeyof
Beiträge: 1019
Registriert: Mi 13. Mai 2020, 10:04
Hat sich bedankt: 22 Mal
Danksagung erhalten: 136 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von Bogeyof »

Und das Originaltemplate aus dem Github funktioniert nicht?
https://tasmota.github.io/docs/devices/ ... -attention

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

Hallo Bogeyof,

negativ..hab hier drei Templates zur Auswahl, nix geht. Irgendwo im web fragen einige Shelly User ebenso nach den richtigen Settings, das war aber zur Tasmota Version ab 6-7 aufwärts, also schon länger her.
Ich hab langsam den Verdacht, das geht mit den roten Shellys überhaupt nicht sauber..denn schon im Original Zustand mit shelly app war es extrem schwer und vollkommen kompliziert, die in die Shelly Cloud einzubinden. Und auch da zeigte sich eine Eigenart..das Relais "prellt", besser, es führt je nach Last ein gewisses Eigenleben, mal an, mal aus, dann aufgehangen,reset..reproduzierbar.

Nach dem Tasmota Flash zeigt das Relais die gleichen Dummheiten, das andere aber weniger, aber prellt dann halt nach paar weiteren Schaltspielen genauso.

Evtl anstelle 12.3.1 ne ältere Tasmota aufspielen? Hardware defekt eines 1PM kann ich fast ausschliessen, ich hab 3 von den Dingern, alle kränkeln..Serienfehler??

Neue blaue Shelly 2.5 sind unterwegs...
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

Teil2..

hier sieht man die IP Oberfläche des shelly
Screenshot 2023-01-18 at 13-40-31 shelly - Hauptmenü.png
Screenshot 2023-01-18 at 13-40-31 shelly - Hauptmenü.png (23.57 KiB) 110 mal betrachtet
und hier die dazugehörige Influx...mit obigem Template aus github

name: Summen
time Wh_Gesamt Wh_Gestern Wh_Heute
---- --------- ---------- --------
2023-01-18T12:37:01Z 31 0
2023-01-18T10:49:01Z 29 0
2023-01-18T10:48:01Z 28 0
2023-01-18T10:47:01Z 28 0
2023-01-18T10:46:01Z 27 0
2023-01-18T10:45:01Z 26 0
2023-01-18T10:43:01Z 25 0
2023-01-18T10:42:01Z 24 0
2023-01-18T10:41:02Z 24 24
2023-01-18T10:40:01Z 24 24
2023-01-18T10:39:01Z 24 24
2023-01-18T10:38:01Z 24 24
2023-01-18T10:37:01Z 24 24

obwohl er die Gesamt Wh mit schreibt, nach copy des Original Templates stoppt er wh_Heute
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

neuere Erkenntnis zu den Shelly 1PM

das github template im Original schaut so aus
{"NAME":"Shelly 1PM","GPIO":[56,0,0,0,82,134,0,0,0,0,0,21,0],"FLAG":2,"BASE":18}

nach Einfügen und aktivieren, abspeichern, macht dann der Shelly DAS daraus
{"NAME":"Shelly 1PM","GPIO":[320,0,0,0,192,2720,0,0,0,0,0,224,0,4736],"FLAG":0,"BASE":18}

und, erschwerend kommt hinzu, dass der Shelly 1PM scheinbar NUR LASTFREI schalten kann, ohne sich aufzuhängen...bei ner popeligen Last von grad 60W als Test, hängt er sich nach 4-5mal schalten einfach auf.Oder er zeigt im IP Display ON, steht aber auf OFF

Ich mag mir das bei einem Mio Produkt eigentlich nicht vorstellen, aber selbst ältere Tasmota Versionen bis runter 8.5.x funzen mit dem Teil schlicht und ergreifend nicht.

Hat denn wirklich keiner hier im Forum das Teil unter Tasmota einwandfrei laufen und kann Hilfe geben welche Version und welches Template?
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

so, heute kamen die shelly 2.5 und plus 2.5.

Den 2.5er ausgepackt, via original APP versucht anzubinden, auch hier wieder krasse Abweichung zur Beschreibung, erst nach 6maligem Powercycle will dat dingen den WiFi Accesspoint rausrücken...egal, bins ja gewohnt. Da den Shelly kurz angetestet ob alles geht, ja geht, zeigt Leistung etc an.passt.

Dann Tasmota 12.3.1 drauf geflasht und das passende Template eingefügt, geht schonmal mehr. Diesen Shelly kann ich per Mausklick im sek Takt schalten, ohne dass er sich wie der 1PM aufhängt. In die Influx geschaut, oha, tut sich was, aber...

ABER: in Tasmota zeigt er keine Leistung, keinen Strom an..und die VAr Werte sind auch Hausnummern, egal welches Template ich unter github raus fische und was man manuell anklicken kann,
Screenshot 2023-01-19 at 12-31-38 Shelly 2.5 - Main Menu.png
Ich hab jetzt bald 5Tage und Nächte rum, die Dinger mögen am Mars funzen..ich jedenfalls pack den Shelly 2plus nichmal mehr aus..

entweder bin ich zu doof dast Teil einzurichten oder Tasmota Version und Templates passen nicht zueinander.

Wer die Lösung hat, möge es bitte hier reinschreiben, bis dahin feuer ich das Shelly Zeugs in die Ecke :(
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

einen wollt ich noch, weils mir gar keine Ruhe gelassen hatte..
Screenshot 2023-01-19 at 14-07-54 Shelly 2.5 - Hauptmenü.png
ich hab den Shelly 2.5 via OTA (das serielle pinout mit 1,27er Raster ist mir zu heikel) auf eine ältere Version geflasht

tja, nix template, nix googeln..nix rätseln, nur staunen..die etwas hohen VAr Werte korrigiere ich noch auf Konsolenebene, aber tut was er soll und die Influx auch

Tasmota 12.3.1 (latest,Stand heute) daher nicht flashen!

http://ota.tasmota.com/tasmota32/release-10.1.0/
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

andreas_n
Beiträge: 792
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 20 Mal
Danksagung erhalten: 44 Mal

Re: SHELLY 1PM flashen, aber (fast)keine Daten in Influx..

Beitrag von andreas_n »

Nachtrag:

Leider verliert der Shelly 2.5 die Daten, wenn er stromlos wird und da er in der Automation zwar geht, aber beide Relais zusammen geschalten werden, ist er auch nicht als "Dual" verwendbar...also ist er eigentlich total unbrauchbar für solche Zwecke

:(
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)
3,8kWp S > Growatt SPH 4600 (IBN 22.10.21)

Antworten