Seit dem Update falsche Werte an MQTT

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Antworten
acsolar
Beiträge: 14
Registriert: Mi 15. Sep 2021, 08:22

Seit dem Update falsche Werte an MQTT

Beitrag von acsolar »

Hallo,
seit dem Update werden zeitweise falsche Werte an den MQTT übertragen.
falsche Werte an MQTT
falsche Werte an MQTT
Hier der aktuelle Log
08.05. 16:55:00 -Multi Regler Auslesen [Start].
08.05. 16:55:00 -Verarbeitung von: '1.user.config.php' Regler: 62
08.05. 16:55:00 |---------------- Start huawei_LAN.php -----------------------------
08.05. 16:55:00 -Huawei: 10.0.0.81 Port: 502 GeräteID: 1
08.05. 16:55:04 > -Gerätetyp: Modell ID: 0
08.05. 16:55:09 -MQTT Daten zum [ 10.0.0.91 ] senden.
08.05. 16:55:09 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
08.05. 16:55:09 -Multi-Regler-Ausgang. 0
08.05. 16:55:09 -OK. Datenübertragung erfolgreich.
08.05. 16:55:09 |---------------- Stop huawei_LAN.php ---------------------------
08.05. 16:55:09 -Verarbeitung von: '2.user.config.php' Regler: 62
08.05. 16:55:09 |---------------- Start huawei_LAN.php -----------------------------
08.05. 16:55:09 -Huawei: 10.0.0.81 Port: 502 GeräteID: 2
08.05. 16:55:09 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: 10.0.0.91 Port: 1883
08.05. 16:55:11 > -Gerätetyp: Modell ID: 0
08.05. 16:55:20 -MQTT Daten zum [ 10.0.0.91 ] senden.
08.05. 16:55:20 * -Daten zur lokalen InfluxDB [ solaranzeige2 ] gesendet.
08.05. 16:55:20 -Multi-Regler-Ausgang. -2
08.05. 16:55:20 -OK. Datenübertragung erfolgreich.
08.05. 16:55:20 |---------------- Stop huawei_LAN.php ---------------------------
08.05. 16:55:20 -Verarbeitung von: '3.user.config.php' Regler: 62
08.05. 16:55:20 |---------------- Start huawei_LAN.php -----------------------------
08.05. 16:55:20 -Huawei: 10.0.0.81 Port: 502 GeräteID: 3
08.05. 16:55:20 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: 10.0.0.91 Port: 1883
08.05. 16:55:24 > -Gerätetyp: SUN2000-10KTL-M Modell ID: 429
08.05. 16:55:30 -MQTT Daten zum [ 10.0.0.91 ] senden.
08.05. 16:55:30 * -Daten zur lokalen InfluxDB [ solaranzeige3 ] gesendet.
08.05. 16:55:30 -Multi-Regler-Ausgang. -1
08.05. 16:55:30 -OK. Datenübertragung erfolgreich.
08.05. 16:55:30 |---------------- Stop huawei_LAN.php ---------------------------
08.05. 16:55:31 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: 10.0.0.91 Port: 1883
08.05. 16:55:31 -Multi Regler Auslesen [Stop].

Dieses Attribut (SOC) ist nur ein Beispiel da er über langen Zeitraum konstant bleibt, das Verhalten betrifft leider alle Attribute.

Gibt es eine Möglichkeit zum Downgrade?

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Seit dem Update falsche Werte an MQTT

Beitrag von Ulrich »

Von welchem der 3 Geräte denn?
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

acsolar
Beiträge: 14
Registriert: Mi 15. Sep 2021, 08:22

Re: Seit dem Update falsche Werte an MQTT

Beitrag von acsolar »

Leider bei allen 3 WRs.
Kann aber kein Muster zwischen den WRs erkennen
SOC WR1
SOC WR1
SOC WR1
SOC WR1

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Seit dem Update falsche Werte an MQTT

Beitrag von Ulrich »

Kannst du einmal ein Beispiel geben, wo die MQTT Daten falsch sind?
Die ersten beiden Geräte melden doch schon keinen Gerätetyp und kein Modell.
Da stimmt doch schon von vorne herein etwas nicht.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

acsolar
Beiträge: 14
Registriert: Mi 15. Sep 2021, 08:22

Re: Seit dem Update falsche Werte an MQTT

Beitrag von acsolar »

Hallo Ulrich,

die Bilder sind Beispiele SOC über MQTT geliefert. Sollte konstant 100 liefern.

hier der Logfile wenn richtige Werte geliefert werden
08.05. 20:11:02 -Multi Regler Auslesen [Start].
08.05. 20:11:02 -Verarbeitung von: '1.user.config.php' Regler: 62
08.05. 20:11:02 |---------------- Start huawei_LAN.php -----------------------------
08.05. 20:11:02 -Huawei: 10.0.0.81 Port: 502 GeräteID: 1
08.05. 20:11:05 > -Gerätetyp: SUN2000-10KTL-M Modell ID: 429
08.05. 20:11:11 -MQTT Daten zum [ 10.0.0.91 ] senden.
08.05. 20:11:11 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
08.05. 20:11:11 -Multi-Regler-Ausgang. 0
08.05. 20:11:11 -OK. Datenübertragung erfolgreich.
08.05. 20:11:11 |---------------- Stop huawei_LAN.php ---------------------------
08.05. 20:11:11 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: 10.0.0.91 Port: 1883
08.05. 20:11:11 -Verarbeitung von: '2.user.config.php' Regler: 62
08.05. 20:11:11 |---------------- Start huawei_LAN.php -----------------------------
08.05. 20:11:11 -Huawei: 10.0.0.81 Port: 502 GeräteID: 2
08.05. 20:11:14 > -Gerätetyp: SUN2000-10KTL-M Modell ID: 429
08.05. 20:11:19 -MQTT Daten zum [ 10.0.0.91 ] senden.
08.05. 20:11:19 * -Daten zur lokalen InfluxDB [ solaranzeige2 ] gesendet.
08.05. 20:11:19 -Multi-Regler-Ausgang. 1
08.05. 20:11:19 -OK. Datenübertragung erfolgreich.
08.05. 20:11:19 |---------------- Stop huawei_LAN.php ---------------------------
08.05. 20:11:20 -Verarbeitung von: '3.user.config.php' Regler: 62
08.05. 20:11:20 |---------------- Start huawei_LAN.php -----------------------------
08.05. 20:11:20 -Huawei: 10.0.0.81 Port: 502 GeräteID: 3
08.05. 20:11:20 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: 10.0.0.91 Port: 1883
08.05. 20:11:23 > -Gerätetyp: SUN2000-10KTL-M Modell ID: 429
08.05. 20:11:29 -MQTT Daten zum [ 10.0.0.91 ] senden.
08.05. 20:11:29 * -Daten zur lokalen InfluxDB [ solaranzeige3 ] gesendet.
08.05. 20:11:29 -Multi-Regler-Ausgang. 0
08.05. 20:11:29 -OK. Datenübertragung erfolgreich.
08.05. 20:11:29 |---------------- Stop huawei_LAN.php ---------------------------
08.05. 20:11:29 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: 10.0.0.91 Port: 1883
08.05. 20:11:30 -Multi Regler Auslesen [Stop].

Danke für Deine Unterstützung
Axel

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Seit dem Update falsche Werte an MQTT

Beitrag von Ulrich »

Hallo Axel,

das hilft mir nicht. Ich benötige die MQTT Daten, die zum Brocker gesendet werden.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

acsolar
Beiträge: 14
Registriert: Mi 15. Sep 2021, 08:22

Re: Seit dem Update falsche Werte an MQTT

Beitrag von acsolar »

Hallo,
wie und wo soll ich die Abgreifen? ich weiß nur wie ich die Daten liefern kann, die am Broker ankommen.

Axel

acsolar
Beiträge: 14
Registriert: Mi 15. Sep 2021, 08:22

Re: Seit dem Update falsche Werte an MQTT

Beitrag von acsolar »

Hallo
habe nun mit 32 und 64 bit und beide Versionen im Single und Multi Mode getestet.
Immer das selbe Ergebnis.

LG
Axel

acsolar
Beiträge: 14
Registriert: Mi 15. Sep 2021, 08:22

Re: Seit dem Update falsche Werte an MQTT

Beitrag von acsolar »

Hallo,

so wie es aussieht ist es kein MQTT Problem.
Grafana zeigt auch die 0 Werte. Neue 64 Bit Installation
Screenshot 2023-05-10 123330.jpg

Antworten

Zurück zu „Multi-Regler-Version [ bis zu 6 Geräten an einem Raspberry Pi ]“