Solaranzeige geht nicht mehr

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

maximinus
Beiträge: 51
Registriert: Sa 25. Jul 2020, 14:35
Wohnort: Tullnerbach bei Wien

Solaranzeige geht nicht mehr

Beitrag von maximinus »

Seit heute 14:00 steht das dashboard still. Ich wollte die Anzeige aktualisieren aber es ging nichts mehr. Ich habe dann das dashboard nochmals aufgerufen, aber es kam die Meldung:
solaranzeige plugin failed
ChunkLoadError: Loading chunk 5783 failed. (error: http://192.168.178.159:3000/public/buil ... be6ec7f.js)
Ich wollte das dann mit putty ansehen kann den user "pi" eingeben aber es wird das passwort "solaranzeige" nicht akzeptiert.
Bevor ich eine hard reset mache will ich nur sicher gehen das ich da nicht noch mehr kaputt mache.
Gibt es da eine Lösung
LG Gerhard

8ung
Beiträge: 17
Registriert: Do 8. Jun 2023, 06:43
Hat sich bedankt: 4 Mal

Re: Solaranzeige geht nicht mehr

Beitrag von 8ung »

und den User root schon probiert?

TeamO
Beiträge: 1150
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 24 Mal
Danksagung erhalten: 231 Mal

Re: Solaranzeige geht nicht mehr

Beitrag von TeamO »

Hast Du die SD-Karte nach der Installation komplett freigegeben?
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

maximinus
Beiträge: 51
Registriert: Sa 25. Jul 2020, 14:35
Wohnort: Tullnerbach bei Wien

Re: Solaranzeige geht nicht mehr

Beitrag von maximinus »

@8tung
root verlangt nach einem Passwort. "solaranzeige " wird nicht angenommen.

@TeamO

Es läuft auf einer 60GB SSD die ich freigegeben hatte.

Das Merkwürdige ist dass ich keinerlei Eingriffe vorgenommen habe außer das Grafana dashboard anzusehen. Solaranzeige läuft seit Sommer vorigen Jahres anstandslos, nachdem ich zuvor schon öfter Abstürze hatte.

Viewlleicht ein Hinweis:
Solaranzeige läuft als Multiregler mit 2 WR tType 26
Die grüne LED blinkt regelmäßig aber die blaue der SSD leuchtet ständig.

Benutzeravatar
Ulrich
Administrator
Beiträge: 5607
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 891 Mal
Kontaktdaten:

Re: Solaranzeige geht nicht mehr

Beitrag von Ulrich »

Hier findest du die richtigen Kennwörter:
viewtopic.php?t=77
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

maximinus
Beiträge: 51
Registriert: Sa 25. Jul 2020, 14:35
Wohnort: Tullnerbach bei Wien

Re: Solaranzeige geht nicht mehr

Beitrag von maximinus »

alle Passworter werden abgelehnt Accsess denied.
Ich werde mal die Stromversorgung abstecken und neu booten.

Danke.
Gerhard

maximinus
Beiträge: 51
Registriert: Sa 25. Jul 2020, 14:35
Wohnort: Tullnerbach bei Wien

Re: Solaranzeige geht nicht mehr (gelöst)

Beitrag von maximinus »

Ich weiß zwar nicht warum. aber nach dem Botten ggeht wieder alles

Danke für die Unterstützung

Gerhard

maximinus
Beiträge: 51
Registriert: Sa 25. Jul 2020, 14:35
Wohnort: Tullnerbach bei Wien

Re: Solaranzeige geht nicht mehr

Beitrag von maximinus »

Leider war das nicht von Dauer.
Seit 2 Tagen steht die Solaranzeige am morgen wenn ich die Daten des Vortages inspizieren möchte.
Obwohl die Anzeige immer das gleiche aussagt scheint die Ursache aber eine andere zu sein.
Während der Abendstunden endet die Aufzeichnung der Daten. Sie kommen auch nicht mehr in die Datenbank die am Raspi des ioBrokers läuft.
Obwohl ein Ping auf die Solaranzeige möglich ist kann ich mit Putty nicht darauf zugreifen.
Nach dem booten schaue ich in die Solarlogdatei
Sie beendete die Aufzeichnungen zuletzt gestern 20:08:14 ohne einen Fehler und beginnt heute nach dem reboot um 09:03:48

Die php-log zeigt seit

Code: Alles auswählen

:[17-Jun-2023 20:02:04 Europe/Berlin] PHP Notice:  Undefined index: Modell in /var/www/html/qpi_p30.php on line 800
Zuvor sind solche Einträge zu sehen:

Code: Alles auswählen

#0 /var/www/html/mqtt_prozess.php(115): Mosquitto\Client->loop(100)
#1 {main}
  thrown in /var/www/html/mqtt_prozess.php on line 115
[17-Jun-2023 18:30:12 Europe/Berlin] PHP Notice:  Undefined index: Modell in /var/www/html/qpi_p30.php on line 800
[17-Jun-2023 18:31:01 Europe/Berlin] PHP Fatal error:  Uncaught Mosquitto\Exception: The connection was lost. in /var/www/html/mqtt_prozess.php:115
Stack trace:
#0 /var/www/html/mqtt_prozess.php(115): Mosquitto\Client->loop(100)
#1 {main}
  thrown in /var/www/html/mqtt_prozess.php on line 115
Am Beginn der Logdatei ist folgendes zu lesen:

Code: Alles auswählen

[23-Aug-2022 17:08:35 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/usb_init.php on line 10
[23-Aug-2022 17:08:35 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/usb_init.php on line 10
[27-Aug-2022 16:50:01 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 16:50:01 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 17:00:21 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/usb_init.php on line 10
[27-Aug-2022 17:00:22 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/usb_init.php on line 10
[27-Aug-2022 17:09:03 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/usb_init.php on line 10
[27-Aug-2022 17:09:04 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/usb_init.php on line 10
[27-Aug-2022 17:20:01 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 17:20:01 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 17:50:01 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 17:50:01 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 18:20:02 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 18:20:02 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 18:50:01 Europe/Berlin] PHP Warning:  require(/var/www/html/user.config.php): failed to open stream: No such file or directory in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 18:50:01 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/var/www/html/user.config.php' (include_path='.:/usr/share/php') in /var/www/html/wetterdaten.php on line 23
[27-Aug-2022 18:54:01 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 18:55:02 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 18:56:00 Europe/Berlin] PHP Notice:  Undefined variable: USB_Regler in /var/www/html/usb_init.php on line 407
[27-Aug-2022 18:56:00 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 18:57:12 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 18:58:02 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 18:59:01 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 19:00:01 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10
[27-Aug-2022 19:01:01 Europe/Berlin] PHP Warning:  fopen(/dev/hidraw0): failed to open stream: No such file or directory in /var/www/html/phpinc/funktionen.inc.php on line 10

Die Software Version ist 4.8.0.

Könnte ein update da was verbessern oder gibt es eine andere Vermutung über die Ursache?

LG Gerhard

Benutzeravatar
Ulrich
Administrator
Beiträge: 5607
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 891 Mal
Kontaktdaten:

Re: Solaranzeige geht nicht mehr

Beitrag von Ulrich »

Hallo Gerhard,

die Fehlermeldungen deuten darauf hin dass plötzlich verschiedene Dateien nicht mehr vorhanden sind. So wie z.B. die user.config.php

Da das aber nicht sein kann, tippe ich eher auf Probleme mit den Pfaden. Ist das eine Docker Installation?

Du hast doch eine Multi-Regler-Version. Warum wird dann die Datei usb_init.php durchlaufen? Da stimmt doch mit deiner Konfiguration etwas nicht.
Hast du die Änderungen in der crontab nicht gemacht?
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

maximinus
Beiträge: 51
Registriert: Sa 25. Jul 2020, 14:35
Wohnort: Tullnerbach bei Wien

Re: Solaranzeige geht nicht mehr

Beitrag von maximinus »

die Fehlermeldungen deuten darauf hin dass plötzlich verschiedene Dateien nicht mehr vorhanden sind. So wie z.B. die user.config.php

Da das aber nicht sein kann, tippe ich eher auf Probleme mit den Pfaden. Ist das eine Docker Installation?
Nein das läuft auf einem Raspi
Du hast doch eine Multi-Regler-Version. Warum wird dann die Datei usb_init.php durchlaufen? Da stimmt doch mit deiner Konfiguration etwas nicht.
Hast du die Änderungen in der crontab nicht gemacht?
Doch habe ich gemacht, aber wie ich es jetzt kontrolliert habe hat sich ein Schreibfehler eingeschlichen: statt multi_usb_init.php stand da nur mult_usb_init.php (das "i" hat gefehlt)
ich habe in der Solaranzeige seit der Einrichtung nie mehr etwas verändert. Kann das sein das bisher soweit überhaupt funktioniert hat?
Solaranzeige läuft nach dem reboot wieder.
Ich warte mit einem allfälligen update noch.

Danke

Gerhard

Antworten

Zurück zu „Allgemeines“