Deye Hybrid 10k läuft irgendwie nicht

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
TorstenB
Beiträge: 9
Registriert: So 17. Dez 2023, 14:36

Deye Hybrid 10k läuft irgendwie nicht

Beitrag von TorstenB »

Guten Abend,
habe heute Solaranzeiger auf einem nagelneuen Raspi 4B in Betrieb genommen, aber offenbar funktioniert die Kommunikation noch nicht so recht.

19.12. 21:08:01 |------------------------- Start deye_wr.php ---------------------
19.12. 21:08:01 + -WR_ID: 01 USB: /dev/ttyUSB0
19.12. 21:08:02 -Gerätetyp: 0500
19.12. 21:08:02 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:03 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:03 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
19.12. 21:08:09 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
19.12. 21:08:17 -Gerätetyp: 0500
19.12. 21:08:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:19 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
19.12. 21:08:25 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
19.12. 21:08:32 -Gerätetyp: 0500
19.12. 21:08:32 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:32 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:33 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:33 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:34 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:34 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
19.12. 21:08:40 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
19.12. 21:08:45 -Gerätetyp: 0500
19.12. 21:08:45 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:45 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:45 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:46 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:47 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:47 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
19.12. 21:08:53 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
19.12. 21:08:55 -Gerätetyp: 0500
19.12. 21:08:57 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:57 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:58 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:58 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:58 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:58 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:58 -Falsche Daten kommen zurück. Noch einmal versuchen.
19.12. 21:08:58 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
19.12. 21:09:05 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
19.12. 21:09:05 -OK. Datenübertragung erfolgreich.
19.12. 21:09:05 |------------------------- Stop deye_wr.php ---------------------

Im Dashboard werden recht merkwürdige Verbrauchsdaten angezeigt --> siehe Anhang --> demnach habe ich heute schon 1,2 Megawatt/h verbraucht, bei 8 kw/h Bezug und Null Ertrag (ist auch recht dunkelgrau heute gewesen).

Ich habe das Gefühl, dass ich ein multiples Problem habe und habe keine Ahnung, wo ich ansetzen soll.
Angeschlossen am RS485, jedoch wundere ich mich auch, dass ich im Dashboard nix über den Akku sehe.

Hat jemand eine Idee? Vielen lieben Dank schon jetzt
Dateianhänge
Verbrauch.jpg

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Deye Hybrid 10k läuft irgendwie nicht

Beitrag von Ulrich »

Laut LOG Datei kommen ab und zu richtige Daten an.
Sind diese Vorgaben alle bachtet?
viewtopic.php?t=1069

Es sieht so aus, als ob der Adapter einen Wackelkontakt hat.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

TorstenB
Beiträge: 9
Registriert: So 17. Dez 2023, 14:36

Re: Deye Hybrid 10k läuft irgendwie nicht

Beitrag von TorstenB »

Moin Ulrich, vielen Dank.
Wackelkontakt könnte sein, sind ja echt dünne Drähte. Hab die Drahtenden nun ordentlich mit dem Lötkolben verzinnt und neu in den USB Adapter eingeschraubt. Ein Wackelkontakt sollte nun ausgeschlossen sein. Aber die Log-Datei sieht nicht wirklich besser aus:

Hast Du eine Idee?


21.12. 11:48:56 |------------------------- Stop deye_wr.php ---------------------
21.12. 11:49:01 |------------------------- Start deye_wr.php ---------------------
21.12. 11:49:01 + -WR_ID: 01 USB: /dev/ttyUSB0
21.12. 11:49:01 -Gerätetyp: 0500
21.12. 11:49:01 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:02 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:02 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:03 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
21.12. 11:49:09 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:09 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:11 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
21.12. 11:49:19 -Gerätetyp: 0500
21.12. 11:49:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:21 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
21.12. 11:49:27 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:27 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:29 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
21.12. 11:49:34 -Gerätetyp: 0500
21.12. 11:49:35 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:35 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:35 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:35 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:36 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
21.12. 11:49:42 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
21.12. 11:49:45 -Gerätetyp: 0500
21.12. 11:49:45 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:46 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:46 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:46 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:46 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:46 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:46 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW
21.12. 11:49:53 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
21.12. 11:49:54 -Gerätetyp: 0500
21.12. 11:49:55 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:55 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:56 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:56 -Falsche Daten kommen zurück. Noch einmal versuchen.
21.12. 11:49:57 -Protokoll Version: 104, Dashboard: Deye Hybrid Wechselrichter, Nennleistung: 10 kW

.....
....

21.12. 11:51:45 -InfluxDB => [ Info Geraetetyp="0500",Firmware="0104",Seriennummer=,Objekt="",Datum="21.12.2023" 1703155891
Service Nennleistung=10000,Anz_MPPT=2,Anz_Phasen=3,Status=2,Transformator_Temperatur=25,Kuehlkoerper_Temperatur=39.4 1703155891
Summen WattstundenGesamtHeute=0,BetriebsstundenGesamt=0,LadungBatterieHeute=0,EntladungBatterieHeute=300,LadungBatterieGesamt=6400,EntladungBatterieGesamt=14300,BezugHeute>
Batterie Batterie1_Temperatur=-83.5,Batterie1_Spannung=51.5,Batterie1_SOC=20,Batterie2_SOC=0,Batterie_Leistung=-65,Batterie1_Strom=-1.28,Restkapazitaet=200,Batterie2_Spann>
GRID Netzspannung_R=239,Netzspannung_S=237.3,Netzspannung_T=236.2,OUT-Leistung_R=278,OUT-Leistung_S=85,OUT-Leistung_T=-14,OUT-Gesamtleistung=349,Netzseite-Gesamtleistung=0>
INV Spannung_R=239.7,Spannung_S=236.7,Spannung_T=236.5,Strom_R=-0.1,Strom_S=-0.1,Strom_T=-0.3,Leistung_R=65,Leistung_S=45,Leistung_T=-179,Leistung=-69,Frequenz=50 17031558>
USV Leistung_R=17,Leistung_S=0,Leistung_T=14,Leistung=34 1703155891
LOAD Spannung_R=239.6,Spannung_S=237.6,Spannung_T=236.9,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=349,Leistung_S=137,Leistung_T=0,Leistung=264,Frequenz=50 1703155891
GEN Spannung_R=0.6,Spannung_S=0.4,Spannung_T=0.5,Leistung_R=0,Leistung_S=0,Leistung_T=0,Leistung=0 1703155891
PV PV1_Leistung=0,PV2_Leistung=0,PV1_Spannung=142.3,PV1_Strom=0,PV2_Spannung=90.8,PV2_Strom=0,PV_Leistung=0 1703155891
Statistik Timestamp=1703155905,Monat=12,Woche=51,Wochentag="Donnerstag",Uhrzeit="11:51:45" 1703155891
]
21.12. 11:51:45 -Daten nicht zur lokalen InfluxDB gesendet! info: array (
'url' => 'http://localhost/write?db=solaranzeige&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 448,
'request_size' => 1903,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.012681,
'namelookup_time' => 6.7E-5,
'connect_time' => 0.000351,
'pretransfer_time' => 0.000468,
'size_upload' => 1745.0,
'size_download' => 178.0,
'speed_download' => 14036.0,
'speed_upload' => 137607.0,
'download_content_length' => 178.0,
'upload_content_length' => 1745.0,
'starttransfer_time' => 0.012625,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '127.0.0.1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '127.0.0.1',
'local_port' => 39298,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 0,
'connect_time_us' => 351,
'namelookup_time_us' => 67,
'pretransfer_time_us' => 468,
'redirect_time_us' => 0,
'starttransfer_time_us' => 12625,
'total_time_us' => 12681,
)
21.12. 11:51:50 -InfluxDB => [ Info Geraetetyp="0500",Firmware="0104",Seriennummer=,Objekt="",Datum="21.12.2023" 1703155891
Service Nennleistung=10000,Anz_MPPT=2,Anz_Phasen=3,Status=2,Transformator_Temperatur=25,Kuehlkoerper_Temperatur=39.4 1703155891
Summen WattstundenGesamtHeute=0,BetriebsstundenGesamt=0,LadungBatterieHeute=0,EntladungBatterieHeute=300,LadungBatterieGesamt=6400,EntladungBatterieGesamt=14300,BezugHeute>
Batterie Batterie1_Temperatur=-83.5,Batterie1_Spannung=51.5,Batterie1_SOC=20,Batterie2_SOC=0,Batterie_Leistung=-65,Batterie1_Strom=-1.28,Restkapazitaet=200,Batterie2_Spann>
GRID Netzspannung_R=239,Netzspannung_S=237.3,Netzspannung_T=236.2,OUT-Leistung_R=278,OUT-Leistung_S=85,OUT-Leistung_T=-14,OUT-Gesamtleistung=349,Netzseite-Gesamtleistung=0>
INV Spannung_R=239.7,Spannung_S=236.7,Spannung_T=236.5,Strom_R=-0.1,Strom_S=-0.1,Strom_T=-0.3,Leistung_R=65,Leistung_S=45,Leistung_T=-179,Leistung=-69,Frequenz=50 17031558>
USV Leistung_R=17,Leistung_S=0,Leistung_T=14,Leistung=34 1703155891
LOAD Spannung_R=239.6,Spannung_S=237.6,Spannung_T=236.9,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=349,Leistung_S=137,Leistung_T=0,Leistung=264,Frequenz=50 1703155891
GEN Spannung_R=0.6,Spannung_S=0.4,Spannung_T=0.5,Leistung_R=0,Leistung_S=0,Leistung_T=0,Leistung=0 1703155891
PV PV1_Leistung=0,PV2_Leistung=0,PV1_Spannung=142.3,PV1_Strom=0,PV2_Spannung=90.8,PV2_Strom=0,PV_Leistung=0 1703155891
Statistik Timestamp=1703155905,Monat=12,Woche=51,Wochentag="Donnerstag",Uhrzeit="11:51:45" 1703155891
]

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Deye Hybrid 10k läuft irgendwie nicht

Beitrag von Ulrich »

Das Problem ist laut LOG Datei, dass dein Gerät die Seriennummer nicht liefert. Kannst du bitte noch einmal ein Update auf die Solaranzeige machen? Dann sollte es funktionieren mit Seriennummer = 0
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

TorstenB
Beiträge: 9
Registriert: So 17. Dez 2023, 14:36

Re: Deye Hybrid 10k läuft irgendwie nicht

Beitrag von TorstenB »

Vielen Dank, hat leider nicht geholfen, ich hatte ja auch das frische Image 6.0.0 32 Bit verwendet.

Antworten

Zurück zu „Allgemeines“